[FIXED] npm install -> Failed at the node-sass@4.9.3 postinstall script

Issue

I’m trying to do npm install and an error appears :

Failed at the node-sass@4.9.3 postinstall script.

enter image description here

npm : 6.14.11

node : 16.15.0

I tried to delete node_modules and then reinstall it, same error appears. what will be the solution?

I clean the cache with : npm cache clean --force
I delete the package-lock.json

I have uninstall et reinstall multiple time. I restart the computer.

I don’t know what to do …

Thanks in advance for your help

Full log under

52254 silly saveTree | | | | | | `-- uniq@1.0.1
52254 silly saveTree | | | | | +-- postcss@5.2.18
52254 silly saveTree | | | | | | +-- chalk@1.1.3
52254 silly saveTree | | | | | | | `-- supports-color@2.0.0
52254 silly saveTree | | | | | | `-- supports-color@3.2.3
52254 silly saveTree | | | | | |   `-- has-flag@1.0.0
52254 silly saveTree | | | | | `-- vendors@1.0.4
52254 silly saveTree | | | | +-- postcss-minify-font-values@1.0.5
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-minify-gradients@1.0.5
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-minify-params@1.2.2
52254 silly saveTree | | | | | +-- alphanum-sort@1.0.2
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-minify-selectors@2.1.1
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-normalize-charset@1.1.1
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-normalize-url@3.0.8
52254 silly saveTree | | | | | +-- is-absolute-url@2.1.0
52254 silly saveTree | | | | | +-- normalize-url@1.9.1
52254 silly saveTree | | | | | | +-- prepend-http@1.0.4
52254 silly saveTree | | | | | | +-- query-string@4.3.4
52254 silly saveTree | | | | | | | `-- strict-uri-encode@1.1.0
52254 silly saveTree | | | | | | `-- sort-keys@1.1.2
52254 silly saveTree | | | | | |   `-- is-plain-obj@1.1.0
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-ordered-values@2.2.3
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-reduce-idents@2.4.0
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-reduce-initial@1.0.1
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-reduce-transforms@1.0.4
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-svgo@2.1.6
52254 silly saveTree | | | | | +-- is-svg@2.1.0
52254 silly saveTree | | | | | | `-- html-comment-regex@1.1.2
52254 silly saveTree | | | | | +-- postcss@5.2.18
52254 silly saveTree | | | | | | +-- chalk@1.1.3
52254 silly saveTree | | | | | | | `-- supports-color@2.0.0
52254 silly saveTree | | | | | | `-- supports-color@3.2.3
52254 silly saveTree | | | | | |   `-- has-flag@1.0.0
52254 silly saveTree | | | | | `-- svgo@0.7.2
52254 silly saveTree | | | | |   +-- coa@1.0.4
52254 silly saveTree | | | | |   | `-- q@1.5.1
52254 silly saveTree | | | | |   +-- colors@1.1.2
52254 silly saveTree | | | | |   +-- csso@2.3.2
52254 silly saveTree | | | | |   | `-- clap@1.2.3
52254 silly saveTree | | | | |   |   `-- chalk@1.1.3
52254 silly saveTree | | | | |   +-- js-yaml@3.7.0
52254 silly saveTree | | | | |   | `-- esprima@2.7.3
52254 silly saveTree | | | | |   `-- whet.extend@0.9.9
52254 silly saveTree | | | | +-- postcss-unique-selectors@2.0.2
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | +-- postcss-zindex@2.2.0
52254 silly saveTree | | | | | `-- postcss@5.2.18
52254 silly saveTree | | | | |   +-- chalk@1.1.3
52254 silly saveTree | | | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | | | |   `-- supports-color@3.2.3
52254 silly saveTree | | | | |     `-- has-flag@1.0.0
52254 silly saveTree | | | | `-- postcss@5.2.18
52254 silly saveTree | | | +-- icss-utils@2.1.0
52254 silly saveTree | | | | `-- postcss@6.0.23
52254 silly saveTree | | | |   +-- source-map@0.6.1
52254 silly saveTree | | | |   `-- supports-color@5.5.0
52254 silly saveTree | | | +-- postcss-modules-extract-imports@1.2.1
52254 silly saveTree | | | | `-- postcss@6.0.23
52254 silly saveTree | | | |   +-- chalk@2.4.2
52254 silly saveTree | | | |   | +-- ansi-styles@3.2.1
52254 silly saveTree | | | |   | `-- supports-color@5.5.0
52254 silly saveTree | | | |   |   `-- has-flag@3.0.0
52254 silly saveTree | | | |   +-- source-map@0.6.1
52254 silly saveTree | | | |   `-- supports-color@5.5.0
52254 silly saveTree | | | `-- postcss@5.2.18
52254 silly saveTree | | |   +-- chalk@1.1.3
52254 silly saveTree | | |   | `-- supports-color@2.0.0
52254 silly saveTree | | |   `-- supports-color@3.2.3
52254 silly saveTree | | |     `-- has-flag@1.0.0
52254 silly saveTree | | +-- finalhandler@0.4.1
52254 silly saveTree | | | `-- debug@2.2.0
52254 silly saveTree | | |   `-- ms@0.7.1
52254 silly saveTree | | +-- fs-extra@5.0.0
52254 silly saveTree | | +-- glob@7.0.6
52254 silly saveTree | | +-- gulp-replace@0.5.4
52254 silly saveTree | | | +-- istextorbinary@1.0.2
52254 silly saveTree | | | | +-- binaryextensions@1.0.1
52254 silly saveTree | | | | `-- textextensions@1.0.2
52254 silly saveTree | | | +-- readable-stream@2.3.7
52254 silly saveTree | | | | +-- isarray@1.0.0
52254 silly saveTree | | | | `-- string_decoder@1.1.1
52254 silly saveTree | | | `-- replacestream@4.0.3
52254 silly saveTree | | |   `-- readable-stream@2.3.7
52254 silly saveTree | | |     +-- isarray@1.0.0
52254 silly saveTree | | |     `-- string_decoder@1.1.1
52254 silly saveTree | | +-- html-loader@0.5.5
52254 silly saveTree | | | +-- es6-templates@0.2.3
52254 silly saveTree | | | | `-- recast@0.11.23
52254 silly saveTree | | | |   +-- ast-types@0.9.6
52254 silly saveTree | | | |   `-- esprima@3.1.3
52254 silly saveTree | | | `-- html-minifier@3.5.21
52254 silly saveTree | | |   +-- camel-case@3.0.0
52254 silly saveTree | | |   | +-- no-case@2.3.2
52254 silly saveTree | | |   | | `-- lower-case@1.1.4
52254 silly saveTree | | |   | `-- upper-case@1.1.3
52254 silly saveTree | | |   +-- commander@2.17.1
52254 silly saveTree | | |   +-- he@1.2.0
52254 silly saveTree | | |   +-- param-case@2.1.1
52254 silly saveTree | | |   +-- relateurl@0.2.7
52254 silly saveTree | | |   `-- uglify-js@3.4.10
52254 silly saveTree | | |     +-- commander@2.19.0
52254 silly saveTree | | |     `-- source-map@0.6.1
52254 silly saveTree | | +-- json-schema@0.2.5
52254 silly saveTree | | +-- node-zip@1.1.1
52254 silly saveTree | | | `-- jszip@2.5.0
52254 silly saveTree | | |   `-- pako@0.2.9
52254 silly saveTree | | +-- resolve@1.7.1
52254 silly saveTree | | +-- rimraf@2.6.3
52254 silly saveTree | | | `-- glob@7.2.3
52254 silly saveTree | | +-- serve-static@1.10.3
52254 silly saveTree | | | `-- send@0.13.2
52254 silly saveTree | | |   +-- etag@1.7.0
52254 silly saveTree | | |   +-- fresh@0.3.0
52254 silly saveTree | | |   +-- http-errors@1.3.1
52254 silly saveTree | | |   | `-- statuses@1.2.1
52254 silly saveTree | | |   +-- mime@1.3.4
52254 silly saveTree | | |   +-- range-parser@1.0.3
52254 silly saveTree | | |   `-- statuses@1.2.1
52254 silly saveTree | | +-- source-map-loader@0.2.4
52254 silly saveTree | | +-- uuid@3.1.0
52254 silly saveTree | | +-- webpack-stream@4.0.3
52254 silly saveTree | | | +-- lodash.clone@4.5.0
52254 silly saveTree | | | +-- lodash.some@4.6.0
52254 silly saveTree | | | +-- plugin-error@1.0.1
52254 silly saveTree | | | +-- supports-color@5.5.0
52254 silly saveTree | | | `-- webpack@3.12.0
52254 silly saveTree | | |   +-- supports-color@4.5.0
52254 silly saveTree | | |   | `-- has-flag@2.0.0
52254 silly saveTree | | |   `-- yargs@8.0.2
52254 silly saveTree | | |     +-- cliui@3.2.0
52254 silly saveTree | | |     | `-- string-width@1.0.2
52254 silly saveTree | | |     |   `-- is-fullwidth-code-point@1.0.0
52254 silly saveTree | | |     +-- os-locale@2.1.0
52254 silly saveTree | | |     | +-- execa@0.7.0
52254 silly saveTree | | |     | | +-- cross-spawn@5.1.0
52254 silly saveTree | | |     | | | `-- lru-cache@4.1.5
52254 silly saveTree | | |     | | `-- get-stream@3.0.0
52254 silly saveTree | | |     | +-- lcid@1.0.0
52254 silly saveTree | | |     | | `-- invert-kv@1.0.0
52254 silly saveTree | | |     | `-- mem@1.1.0
52254 silly saveTree | | |     |   `-- mimic-fn@1.2.0
52254 silly saveTree | | |     +-- read-pkg-up@2.0.0
52254 silly saveTree | | |     | `-- read-pkg@2.0.0
52254 silly saveTree | | |     |   +-- load-json-file@2.0.0
52254 silly saveTree | | |     |   | `-- strip-bom@3.0.0
52254 silly saveTree | | |     |   `-- path-type@2.0.0
52254 silly saveTree | | |     `-- yargs-parser@7.0.0
52254 silly saveTree | | +-- webpack@3.12.0
52254 silly saveTree | | `-- xml@1.0.1
52254 silly saveTree | +-- @types/webpack@4.4.0
52254 silly saveTree | +-- gulp@3.9.1
52254 silly saveTree | +-- webpack@3.12.0
52254 silly saveTree | `-- yargs@4.6.0
52254 silly saveTree +-- @microsoft/sp-core-library@1.8.2
52254 silly saveTree | +-- @microsoft/sp-lodash-subset@1.8.2
52254 silly saveTree | | +-- @types/webpack-env@1.13.1
52254 silly saveTree | | `-- tslib@1.9.3
52254 silly saveTree | +-- @types/es6-promise@0.0.33
52254 silly saveTree | `-- @types/webpack-env@1.13.1
52254 silly saveTree +-- @microsoft/sp-lodash-subset@1.8.2
52254 silly saveTree +-- @microsoft/sp-module-interfaces@1.8.2
52254 silly saveTree +-- @microsoft/sp-office-ui-fabric-core@1.8.2
52254 silly saveTree | +-- office-ui-fabric-core@9.6.1-fluent2
52254 silly saveTree | `-- tslib@1.9.3
52254 silly saveTree +-- @microsoft/sp-tslint-rules@1.8.2
52254 silly saveTree +-- @microsoft/sp-webpart-base@1.8.2
52254 silly saveTree | +-- @microsoft/decorators@1.8.2
52254 silly saveTree | | `-- tslib@1.9.3
52254 silly saveTree | +-- @microsoft/sp-component-base@1.8.2
52254 silly saveTree | | +-- @microsoft/sp-diagnostics@1.8.2
52254 silly saveTree | | +-- @microsoft/sp-dynamic-data@1.8.2
52254 silly saveTree | | | `-- tslib@1.9.3
52254 silly saveTree | | +-- @microsoft/sp-http@1.8.2
52254 silly saveTree | | | +-- @microsoft/microsoft-graph-client@1.1.0
52254 silly saveTree | | | | `-- isomorphic-fetch@2.2.1
52254 silly saveTree | | | |   +-- node-fetch@1.7.3
52254 silly saveTree | | | |   | `-- encoding@0.1.13
52254 silly saveTree | | | |   |   `-- iconv-lite@0.6.3
52254 silly saveTree | | | |   `-- whatwg-fetch@3.6.2
52254 silly saveTree | | | +-- @types/adal-angular@1.0.1
52254 silly saveTree | | | +-- adal-angular@1.0.16
52254 silly saveTree | | | `-- tslib@1.9.3
52254 silly saveTree | | +-- @microsoft/sp-loader@1.8.2
52254 silly saveTree | | | +-- @microsoft/office-ui-fabric-react-bundle@1.8.2
52254 silly saveTree | | | | +-- @types/react@16.4.2
52254 silly saveTree | | | | | `-- csstype@2.6.20
52254 silly saveTree | | | | +-- @uifabric/icons@6.4.0
52254 silly saveTree | | | | | +-- @uifabric/set-version@1.1.3
52254 silly saveTree | | | | | `-- @uifabric/styling@6.50.7
52254 silly saveTree | | | | |   +-- @uifabric/merge-styles@6.19.4
52254 silly saveTree | | | | |   `-- @uifabric/utilities@6.45.2
52254 silly saveTree | | | | |     `-- prop-types@15.8.1
52254 silly saveTree | | | | |       `-- react-is@16.13.1
52254 silly saveTree | | | | +-- office-ui-fabric-react@6.143.0
52254 silly saveTree | | | | | +-- @uifabric/foundation@0.8.3
52254 silly saveTree | | | | | | `-- @uifabric/utilities@6.45.2
52254 silly saveTree | | | | | `-- @uifabric/utilities@6.29.4
52254 silly saveTree | | | | +-- react-dom@16.7.0
52254 silly saveTree | | | | | `-- scheduler@0.12.0
52254 silly saveTree | | | | +-- react@16.7.0
52254 silly saveTree | | | | `-- tslib@1.9.3
52254 silly saveTree | | | +-- @microsoft/sp-odata-types@1.8.2
52254 silly saveTree | | | | `-- tslib@1.9.3
52254 silly saveTree | | | +-- @microsoft/sp-page-context@1.8.2
52254 silly saveTree | | | | `-- tslib@1.9.3
52254 silly saveTree | | | +-- @microsoft/sp-polyfills@1.8.2
52254 silly saveTree | | | | +-- es6-collections@0.5.6
52254 silly saveTree | | | | +-- es6-promise@4.1.1
52254 silly saveTree | | | | +-- tslib@1.9.3
52254 silly saveTree | | | | +-- whatwg-fetch@2.0.3
52254 silly saveTree | | | | `-- whatwg-url@4.7.1
52254 silly saveTree | | | |   +-- tr46@0.0.3
52254 silly saveTree | | | |   `-- webidl-conversions@3.0.1
52254 silly saveTree | | | +-- @types/react-dom@16.0.5
52254 silly saveTree | | | | `-- @types/react@16.4.2
52254 silly saveTree | | | +-- @types/react@16.4.2
52254 silly saveTree | | | +-- @types/requirejs@2.1.29
52254 silly saveTree | | | +-- @uifabric/utilities@6.29.4
52254 silly saveTree | | | +-- office-ui-fabric-react@6.143.0
52254 silly saveTree | | | +-- react-dom@16.7.0
52254 silly saveTree | | | +-- react@16.7.0
52254 silly saveTree | | | +-- requirejs@2.1.20
52254 silly saveTree | | | `-- tslib@1.9.3
52254 silly saveTree | | `-- @microsoft/sp-page-context@1.8.2
52254 silly saveTree | +-- @microsoft/sp-diagnostics@1.8.2
52254 silly saveTree | +-- @microsoft/sp-dynamic-data@1.8.2
52254 silly saveTree | +-- @microsoft/sp-http@1.8.2
52254 silly saveTree | +-- @microsoft/sp-loader@1.8.2
52254 silly saveTree | +-- @microsoft/sp-page-context@1.8.2
52254 silly saveTree | +-- @microsoft/sp-property-pane@1.8.2
52254 silly saveTree | | +-- @types/react-dom@16.0.5
52254 silly saveTree | | | `-- @types/react@16.4.2
52254 silly saveTree | | +-- @types/react@16.4.2
52254 silly saveTree | | `-- tslib@1.9.3
52254 silly saveTree | +-- @microsoft/teams-js@1.4.1
52254 silly saveTree | +-- office-ui-fabric-react@6.143.0
52254 silly saveTree | `-- tslib@1.9.3
52254 silly saveTree +-- @microsoft/sp-webpart-workbench@1.8.2
52254 silly saveTree | +-- @microsoft/node-core-library@3.13.0
52254 silly saveTree | | +-- @types/fs-extra@5.0.4
52254 silly saveTree | | `-- fs-extra@7.0.1
52254 silly saveTree | +-- @microsoft/sp-application-base@1.8.2
52254 silly saveTree | | +-- @microsoft/sp-extension-base@1.8.2
52254 silly saveTree | | `-- tslib@1.9.3
52254 silly saveTree | +-- @microsoft/sp-client-preview@1.8.2
52254 silly saveTree | | `-- tslib@1.9.3
52254 silly saveTree | +-- @types/fs-extra@5.0.1
52254 silly saveTree | +-- @types/react-dom@16.0.5
52254 silly saveTree | | `-- @types/react@16.4.2
52254 silly saveTree | +-- @types/react@16.4.2
52254 silly saveTree | +-- @uifabric/variants@6.14.0
52254 silly saveTree | +-- fs-extra@5.0.0
52254 silly saveTree | +-- prop-types@15.6.0
52254 silly saveTree | | `-- fbjs@0.8.18
52254 silly saveTree | |   +-- core-js@1.2.7
52254 silly saveTree | |   +-- promise@7.3.1
52254 silly saveTree | |   `-- ua-parser-js@0.7.31
52254 silly saveTree | `-- tslib@1.9.3
52254 silly saveTree +-- @pnp/common@1.3.11
52254 silly saveTree | +-- adal-angular@1.0.17
52254 silly saveTree | `-- tslib@1.10.0
52254 silly saveTree +-- @pnp/graph@1.3.11
52254 silly saveTree | +-- @microsoft/microsoft-graph-types@1.7.0
52254 silly saveTree | `-- tslib@1.10.0
52254 silly saveTree +-- @pnp/logging@1.3.11
52254 silly saveTree | `-- tslib@1.10.0
52254 silly saveTree +-- @pnp/odata@1.3.11
52254 silly saveTree | `-- tslib@1.10.0
52254 silly saveTree +-- @pnp/sp@1.3.11
52254 silly saveTree | `-- tslib@1.10.0
52254 silly saveTree +-- @pnp/spfx-controls-react@1.10.0
52254 silly saveTree | +-- @pnp/telemetry-js@1.0.0
52254 silly saveTree | | `-- whatwg-fetch@2.0.4
52254 silly saveTree | `-- office-ui-fabric-react@5.120.0
52254 silly saveTree |   +-- @uifabric/icons@5.8.0
52254 silly saveTree |   | `-- @uifabric/styling@5.37.0
52254 silly saveTree |   |   +-- @uifabric/merge-styles@5.17.1
52254 silly saveTree |   |   `-- @uifabric/utilities@5.34.3
52254 silly saveTree |   +-- @uifabric/merge-styles@5.17.1
52254 silly saveTree |   +-- @uifabric/styling@5.37.0
52254 silly saveTree |   `-- @uifabric/utilities@5.34.3
52254 silly saveTree +-- @pnp/spfx-property-controls@1.12.0
52254 silly saveTree | `-- react-ace@5.8.0
52254 silly saveTree |   `-- brace@0.11.1
52254 silly saveTree +-- @types/chai@3.4.34
52254 silly saveTree +-- @types/es6-promise@0.0.33
52254 silly saveTree +-- @types/mocha@2.2.38
52254 silly saveTree +-- @types/react-dom@16.8.0
52254 silly saveTree | `-- @types/react@16.7.22
52254 silly saveTree |   `-- @types/prop-types@15.7.5
52254 silly saveTree +-- @types/react@16.7.22
52254 silly saveTree +-- @types/webpack-env@1.13.1
52254 silly saveTree +-- ajv@6.12.6
52254 silly saveTree +-- gulp@3.9.1
52254 silly saveTree +-- moment@2.29.4
52254 silly saveTree +-- office-ui-fabric-react@6.143.0
52254 silly saveTree +-- react-dom@16.7.0
52254 silly saveTree `-- react@16.7.0
52255 warn optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.3 (node_modules\sane\node_modules\fsevents):
52256 warn notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
52257 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS:    darwin
52257 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch:  any
52257 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS:   win32
52257 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64
52258 warn optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.3.2 (node_modules\chokidar\node_modules\fsevents):
52259 warn notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
52260 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid OS:    darwin
52260 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Valid Arch:  any
52260 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual OS:   win32
52260 verbose notsup SKIPPING OPTIONAL DEPENDENCY: Actual Arch: x64
52261 verbose stack Error: node-sass@4.9.3 postinstall: `node scripts/build.js`
52261 verbose stack Exit status 1
52261 verbose stack     at EventEmitter.<anonymous> (C:\Users\EthanMarchand-BS-Tea\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\index.js:332:16)
52261 verbose stack     at EventEmitter.emit (node:events:527:28)
52261 verbose stack     at ChildProcess.<anonymous> (C:\Users\EthanMarchand-BS-Tea\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
52261 verbose stack     at ChildProcess.emit (node:events:527:28)
52261 verbose stack     at maybeClose (node:internal/child_process:1092:16)
52261 verbose stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:302:5)
52262 verbose pkgid node-sass@4.9.3
52263 verbose cwd C:\Users\EthanMarchand-BS-Tea\source\repos\spfx-birthdays-so-webpart
52264 verbose Windows_NT 10.0.19044
52265 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\EthanMarchand-BS-Tea\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "install"
52266 verbose node v16.15.0
52267 verbose npm  v6.14.11
52268 error code ELIFECYCLE
52269 error errno 1
52270 error node-sass@4.9.3 postinstall: `node scripts/build.js`
52270 error Exit status 1
52271 error Failed at the node-sass@4.9.3 postinstall script.
52271 error This is probably not a problem with npm. There is likely additional logging output above.
52272 verbose exit [ 1, true ]

Solution

Warning: node-sass is deprecated.

Once said, you try to install node-sass v4.9.3 on node v16.15 which is not ok according to node-sass doc: https://www.npmjs.com/package/node-sass

Try update your package.json to use the good node-sass version ie 6.0+ or use node 14.x with node-sass v4.9.3.

Answered By – Alaindeseine

Answer Checked By – Katrina (Easybugfix Volunteer)

Leave a Reply

(*) Required, Your email will not be published